[-] Exploit exception: Permission denied - bind(2) in Ubuntu for Metasploit

If you get this error in Ubuntu for Metasploit you need to run msfconsole as root.

so....
sudo msfconsole

The reason for this error is because you need root-permissions to bind to a port that is less than 1024.